Results 1 to 4 of 4

Thread: Angle problems, urgent help needed

  1. #1
    Serious User
    Join Date
    Aug 2010
    Location
    Sweden
    Posts
    32

    Angle problems, urgent help needed

    Hello dead community, straight to the chase.
    I bought my colleague a standard wii mote for wmc, but it just wont do the work as my previous wii motes.

    The difference are that the old one's are with motion plus, whilist this "new" one is without it.

    I gave him my old osculator file as well as the traktor mapping to him, it "works" in theory, but not in practice.

    What happens is that the angles are in some sort of cycle mode or something, where if i reach the bottom part of the valueframe (0 for example) it will flick around and turn into 127 which is obviously not workable.

    So what happens is that when i turn the wii mote to the right it will lower the filter until i reach about 90 degrees, that's where it turns around and goes back towards the 0 point, and then back again. My old one's just keeps on going all the way to the bottom for as long as i turn them!

    I've been trying and trying to get this to work, but i just coulndt and neither could i find any solutions to my problems online, So this is my last hope..


    Cheers and
    Johannes Drakenberg - Artist / Head of Radio4by4
    - Facebook - Soundcloud - Tour Dates - Youtube -

  2. #2
    Hi Johannes,

    I am sorry, I don't understand. Are you saying that you tried to use the pitch / roll / yaw angles from the accelerometers of a non-MotionPlus Wiimote to replace the data given by the pitch / roll / yaw angles given from the gyroscopes of a MotionPlus Wiimote?

    Could you share a small example?

    Thanks!
    Camille

  3. #3
    Serious User
    Join Date
    Aug 2010
    Location
    Sweden
    Posts
    32
    Hello Camille, Hmm, let's see if i can explain it.

    My previous wii motes are setup in a way that they will just increase the value in traktor, they both have motion plus inside them and they are set in continuous mode, but even though the quick look shows a saw wave type of diagram as i turn the wii mote in any angle given, it will just increase traktors value, Filter for roll for example.

    This new wii mote without motion plus is setup on the side of the old motes, so it doesn't replace anything at all, however, as i turn it clockwise in the roll angle it shows a sine wave diagram. However in traktor, as it reaches the bottom low of the "hz" in osculator, the values of traktor turns around, so when i filter my track clockwise, it will turn around when i have it 90 degrees to the to the right. Turn around as it will start to decrease the value instead of increasing as it should!

    I should perhaps try and raise the output of the new mote, so it has to send more messages before it reached rock bottom?
    *Tried this Pretty much it's top and low values can only reach their spots in a 180 degrees angle.

    Cheers and thanks once again!
    Last edited by Drakenberg; 03-14-2012 at 03:16 PM.
    Johannes Drakenberg - Artist / Head of Radio4by4
    - Facebook - Soundcloud - Tour Dates - Youtube -

  4. #4
    Hy Johannes!

    Unless I did not understand correctly: What baffles me is that you expect to get the same result from different, unrelated sensors.

    I suppose you can get the right result by changing a setting in Traktor. Here, you don't want to use a relative update of the signal, but instead use a direct interaction.

    I am not in front of my computer right now so I can't give you more info, but hopefully it should get you started.


    best,
    Cam

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •