Results 1 to 8 of 8

Thread: Host name for wifi routing

  1. #1

    Host name for wifi routing

    All right, I'm a bit of a noob when it comes to wireless routing. I've written a small test OSC custom controller for my iPad. I'm sending OSC messages through a HOST and PORT number. Now, when running locally with the iPhone simulator the HOST is simply localhost. Once on the device though what does the host need to be route back to OSCulator? My routers ip? my computers ip? my computers sharing name? I want to write a function that can automatically fill in this info, much like TouchOSC, but for now I just need to figure out what needs to be hardcoded first.

    Thanks

  2. #2
    Hi,

    I would recommend that you use the "Bonjour" name of your computer.
    To know or change this host name, go to the Sharing Preferences Pane, this is displayed at the top of the pane. You can use a single word without special characters to make it easy to enter in your program.

    Cam

  3. #3
    Quote Originally Posted by camille View Post
    Hi,

    I would recommend that you use the "Bonjour" name of your computer.
    To know or change this host name, go to the Sharing Preferences Pane, this is displayed at the top of the pane. You can use a single word without special characters to make it easy to enter in your program.

    Cam
    Right that's for if I setup a AdHoc network. Meaning if I create a network with my Mac and connect my iPad to my Mac wirelessly. Is there anyway for running through a general wifi router which my mac is connected too as well as my iPad?

  4. #4
    This isn't specific to the type of wireless network you are using. Unless I haven't exactly understood what you need, here is a link to a technical article from Apple about this subject : http://docs.info.apple.com/article.h...6/en/8324.html

  5. #5
    So I named my macbook sharing, which is running OSCulator, "bonjour". My app sends osc messages to bonjour.local on port 12345. OSCulator is set to listen to 12345. It's not working, but hypothetically this is all it should be set as? Do I need to turn Internet sharing, Remote Apple Events, or something like that on?

  6. #6
    You are almost there.
    If you picked the name "bonjour", the host name should be "bonjour.local".
    Example:
    Screen shot 2012-04-14 at 00.36.27.png

  7. #7
    Yea, it's not working, must be something on my side. Could it be my router?

  8. #8
    Nope, the router has nothing to do with host name resolution.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •